HCV not working after upgrading the code from 623 to 636

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

HCV not working after upgrading the code from 623 to 636

Darwin Tsai
After upgrading the code from 623 to 636 on my test server, I got the message "Online Health Card Validation unavailable" on the E2 - Detail screen. The HCV was working right before I upgrade the code.

Even downgrade the code back to 623, the HCV is still broken!

Anybody run into the same issue ?

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: HCV not working after upgrading the code from 623 to 636

Darwin Tsai
Same HCV problem exists on upgrade from 623 to 641
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: HCV not working after upgrading the code from 623 to 636

Marc Dumontier
Is there anything in the logs?


On Fri, Jul 7, 2017 at 1:45 PM, Darwin Tsai <[hidden email]> wrote:
Same HCV problem exists on upgrade from 623 to 641



--
View this message in context: http://oscarmcmaster.16.x6.nabble.com/HCV-not-working-after-upgrading-the-code-from-623-to-636-tp5009839p5009845.html
Sent from the oscarmcmaster-devel mailing list archive at Nabble.com.

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Oscarmcmaster-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/oscarmcmaster-devel



--

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Oscarmcmaster-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/oscarmcmaster-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: HCV not working after upgrading the code from 623 to 636

Darwin Tsai
In reply to this post by Darwin Tsai
Hi Marc, Because of the large log file,  I will send it to you directly. Thanks !
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: HCV not working after upgrading the code from 623 to 636

Darwin Tsai
This post has NOT been accepted by the mailing list yet.
In reply to this post by Marc Dumontier
Thank again Marc for solving the problem!

As it turned out, the new deb installation did not use the MCEDT/HCV keystore info in the oscar.properties file. Some how it uses a default file outside of oscar.properties with the wrong password of "pass" instead of "changeit", plus some of the path statement was not the one specified in oscar.properties.

Peter, can the deb installation be updated so that we don't run into this problem for existing installation with running MCEDT and online HCV. I will send you log of the terminal session on how Marc isolated and solved the problem. What is best email address to contact you ? You can reach me at tsai@cheerful.com. I will use your email address in the installation update log for now. Thanks !
Loading...